Vista Revisited

December 14, 2007

EDIT: As far as I have found, there is no way to use FairUse4WM with Vista successfully. I may be dumb and not be doing it correctly, but what I read leads me to believe this. There are supposedly other programs and ways to use Ruckus on Vista the same way as you would on XP, I haven’t tried them.

Yesterday I was pleased to learn that I was granted MSDN access at OS level. Basically, I am allowed to download Microsoft products for free up to and including select versions of Windows. As a result, I have Vista Business Edition running on my main computer now.

I guess the first reaction is to say “Ooh, pretty!.” The interface is, at top level, leaps and bounds nicer than XP. Installation was ridiculously pain free; the only input required by me was the key to prove it was valid and then a username and password at the end of installation. During installation Vista gathered up info on my machine and actually installed proper drivers for everything. Ubuntu and XP, try as they may, always fail to get my video card drivers right, so score one for Vista there.

Only driver that wasn’t installed off the bat was my D-Link WDA 2320 wireless adapter. I used the old drivers off of the CD that came with the adapter to get that “working.” Almost as soon as I got done with the installer, the D-Link drivers crashed head-on with Vista. It was pretty bad. The entire system seemed to slow down because of this conflict, and it took me a few minutes of looking around Vista’s new menus to figure out what to do. Basically I just disabled the D-Link applications from starting up using msconfig and things got happy again. I was able to download the Vista-specific drivers from D-Link’s site and since then I haven’t run in to any problems at all with Vista.

Things I like about Vista:

  • More than anything Windows Key+Tab scrolling through programs is convenient. Like Compiz/Beryl but a bit more limited
  • The sidebar and gadgets are handy. I no longer have to compulsively check weather.com, I have a gadget to tell me that kinda stuff. Gadgets may be stolen Widgets, but that idea was stolen from Konfabulator anyway so it all works out
  • [My] Computer shows a visual representation of free space on each partition of each drive. A perpetual reminder that I need to buy a new 750gig hard drive
  • DVD playback is available out of the box. When XP was released, we were all using VHS apparently 😉
  • WMP11 is nice. Nicer than iTunes for sure. Unfortunately, I have to do some configuration to get Ruckus and FairUse4WM working together
  • All my stuff runs on Vista fine as far as tested
  • Sound control is better
  • Vista isn’t nagging me to install the crappy Nvidia IDE drivers that were giving me so many problems before; XP wouldn’t start up without asking about them after I uninstalled them.
  • The theming of Aero is just so pretty. I like the frosted transparency. I truly do. The animations don’t bug me at all either.

Things I’m not totally thrilled about

  • Driver conflicts are initially harder to identify. Not only that, but the computer seemed to slow to a grind when I had one. Perhaps it is just limited to the conflict I had, but it still wasn’t cool. Easy to fix though.
  • User Account Control. It’s good to some extent, and Microsoft HAD to put that in there so people couldn’t whine about “Waaah, something got a hold of my computer and ran malicious crap without me telling it to!” but it does get annoying after about 3 minutes of use. Turning it off is tantamount to destroying The One Ring (and then I Googled it. If Sam and Frodo had Google, their journey would have taken so much less time!)
  • Edition. I am only using Vista Business, since it is what was on MSDN for me. But that is definitely good enough for me. I wonder what differences there are, and then I think: Wikipedia…

Additionally, there were some complications with activation. I kept getting a message about how the license store wasn’t valid. Turned out, as I found on other forums, that it was because I had my RAM either in the wrong configuration or that I have a bad stick of RAM. Took out one stick temporarily and activation went smoothly. Put the stick in in a different DIMM and everything works fine still. MemTest86+ shows no RAM errors at all, so I am banking on the configuration venture.

It’s 10am, I just turned in my Structures final, and I have class starting…now. Running on 3 hours sleep and a lot of stay-awake food and drink.

See you, space cowboy.

Advertisements